Profile Picture

Deploy of Wiki-lib inside existing sitecollection with customized masterpage not working

Posted By Enrico 8 Years Ago
You don't have permission to rate!

Deploy of Wiki-lib inside existing sitecollection with customized...

Author
Message
Enrico
Posted 8 Years Ago
View Quick Profile
Forum Newbie

Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)

Group: Forum Members
Last Active: 8 Years Ago
Posts: 2, Visits: 6
Hi Folks,

has anybody made some experience regarding the deployment of a WikiPlus-lib inside an existing SiteCollection with a modified v4.master ?

Everytime I create a new Wiki-Lib and everytime I try to open this Lib I get an error concerning a not allowed "autoeventwireup"-attribute on that page. The following screenshot shows that error:

http://forum.kwizcom.com/Uploads/Images/ac5769fb-9be7-426a-a551-57bb.JPG

Any hints are really appreciated.

Best regards

Enrico
Igor
Posted 8 Years Ago
View Quick Profile
Supreme Being

Supreme Being (415 reputation)Supreme Being (415 reputation)Supreme Being (415 reputation)Supreme Being (415 reputation)Supreme Being (415 reputation)Supreme Being (415 reputation)Supreme Being (415 reputation)Supreme Being (415 reputation)Supreme Being (415 reputation)

Group: Administrators
Last Active: 4 Years Ago
Posts: 415, Visits: 592
Hi,

The issue was resolved in the latest beta version 2.1.52 and will be included in the next  production version.

To fix it manually you need to edit "InitWiki.aspx" file located in "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\FEATURES\WikiPlusLibrary\WikiPlusLib". You need to remove the property: AutoEventWireup="true" from this line of code:
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="InitWiki.aspx.cs" Inherits="KWizCom.SharePoint.WikiPlus.WikiPlusLibrary.Views.InitWiki, KWizCom.SharePoint.WikiPlus, Version=1.0.0.0, Culture=neutral, PublicKeyToken=30fb4ddbec95ff8f" MasterPageFile="~masterurl/default.master" %>

Thanks,

Igor,
KWizCom 
Enrico
Posted 8 Years Ago
View Quick Profile
Forum Newbie

Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)

Group: Forum Members
Last Active: 8 Years Ago
Posts: 2, Visits: 6

Hi Igor,

 

thankyou very much for your kind reply. I just tried your suggestion. And the above error seems to be gone.

 

Unfortunately, I still miss some point: after my modification ofInitWiki.aspx I get an error telling me the Base-Type KWizCom.SharePoint.WikiPlus.WikiPlusLibrary.Views.InitWikiis not registered as safe. Although my Web-Config did not change. And this linewhich registered the dll is still inside:

<SafeControlAssembly="KWizCom.SharePoint.WikiPlus, Version=1.0.0.0, Culture=neutral,PublicKeyToken=30fb4ddbec95ff8f"Namespace="KWizCom.SharePoint.WikiPlus" TypeName="*"Safe="True" SafeAgainstScript="False" />

 

Here is the new error:

http://forum.kwizcom.com/Uploads/Images/e5178678-f46c-4e72-a439-a39c.JPG

 

 

Best regards

Enrico

Igor
Posted 8 Years Ago
View Quick Profile
Supreme Being

Supreme Being (415 reputation)Supreme Being (415 reputation)Supreme Being (415 reputation)Supreme Being (415 reputation)Supreme Being (415 reputation)Supreme Being (415 reputation)Supreme Being (415 reputation)Supreme Being (415 reputation)Supreme Being (415 reputation)

Group: Administrators
Last Active: 4 Years Ago
Posts: 415, Visits: 592
Hi,

Try to add the SafeControl entry to the web.config:

<SafeControl Assembly="KWizCom.SharePoint.WikiPlus, Version=1.0.0.0, Culture=neutral, PublicKeyToken=30fb4ddbec95ff8f" Namespace="KWizCom.SharePoint.WikiPlus.WikiPlusLibrary.Views" TypeName="*" Safe="True" SafeAgainstScript="False" />

Thanks,

Igor,
KWizCom 


Similar Topics